# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?xm)^
(?:|
[^;"'\r\n]*
(?:
(?:'[^'\r\n]*')|
(?:"[^"\r\n]*")
)*
)
\h*
;\h*([^\r\n]*)
"""
test_str = ("; test\n"
"; \"test\"\n"
"; \"test'\n"
"; 'test'\n"
"; 'test\"\n"
"$x='' ; chaîne \"vide\"\n"
"$x=\"\" ; chaîne \"vide\"\n"
"$x=\"\" ; chaîne 'vide'\n"
"$x = \"aa;aa\" ; Comment-line\n"
"$x = \"a\" ;$x='b'\n"
"$;x = \"aa;aa\" ; Comment-line\n"
"$x=' '' '';'' \";\" \"'' ''\" \"''\"' ; chaîne \"vide\"\n"
"$x=' '' '';'' \";\" \"'' ''\" \"''\"' ; chaîne 'vide'\n"
"$x=\" ' ';' \"\";\"\" \"\"' '\"\" \"\"'\"\"\" ; chaîne \"vide\"\n"
"$x=\" ' ';' \"\";\"\" \"\"' '\"\" \"\"'\"\"\" ; chaîne 'vide'\n\n"
"\"\" ; commentaire\n\n"
"$x = 'bb;b'\n"
"$x = \"bb;b\"\n"
"$x = \" \" & \"bb\"\n\n"
";;;;\n"
"; ; ;\";'\n"
"\";iii\n"
"';uuu;uuu\";uuu';aa\n"
" ; test\n"
"\" i \" ; a ; a\n"
"\" i \" ; ; a ; a\n"
"\" i \" ; a ; a ; a\n")
matches = re.finditer(regex, test_str, re.VERBOSE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.