$re = '/(?xm)^
(?:|
[^;"\'\r\n]*
(?:
(?:\'[^\'\r\n]*\')|
(?:"[^"\r\n]*")
)*
)
\h*
;\h*([^\r\n]*)/xm';
$str = '; test
; "test"
; "test\'
; \'test\'
; \'test"
$x=\'\' ; chaîne "vide"
$x="" ; chaîne "vide"
$x="" ; chaîne \'vide\'
$x = "aa;aa" ; Comment-line
$x = "a" ;$x=\'b\'
$;x = "aa;aa" ; Comment-line
$x=\' \'\' \'\';\'\' ";" "\'\' \'\'" "\'\'"\' ; chaîne "vide"
$x=\' \'\' \'\';\'\' ";" "\'\' \'\'" "\'\'"\' ; chaîne \'vide\'
$x=" \' \';\' "";"" ""\' \'"" ""\'""" ; chaîne "vide"
$x=" \' \';\' "";"" ""\' \'"" ""\'""" ; chaîne \'vide\'
"" ; commentaire
$x = \'bb;b\'
$x = "bb;b"
$x = " " & "bb"
;;;;
; ; ;";\'
";iii
\';uuu;uuu";uuu\';aa
; test
" i " ; a ; a
" i " ; ; a ; a
" i " ; a ; a ; a
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);