using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?xm)^
(?:|
[^;""'\r\n]*
(?:
(?:'[^'\r\n]*')|
(?:""[^""\r\n]*"")
)*
)
\h*
;\h*([^\r\n]*)";
string input = @"; test
; ""test""
; ""test'
; 'test'
; 'test""
$x='' ; chaîne ""vide""
$x="" ; chaîne ""vide""
$x="" ; chaîne 'vide'
$x = ""aa;aa"" ; Comment-line
$x = ""a"" ;$x='b'
$;x = ""aa;aa"" ; Comment-line
$x=' '' '';'' "";"" ""'' ''"" ""''""' ; chaîne ""vide""
$x=' '' '';'' "";"" ""'' ''"" ""''""' ; chaîne 'vide'
$x="" ' ';' "";"" ""' '"" ""'"""" ; chaîne ""vide""
$x="" ' ';' "";"" ""' '"" ""'"""" ; chaîne 'vide'
"" ; commentaire
$x = 'bb;b'
$x = ""bb;b""
$x = "" "" & ""bb""
;;;;
; ; ;"";'
"";iii
';uuu;uuu"";uuu';aa
; test
"" i "" ; a ; a
"" i "" ; ; a ; a
"" i "" ; a ; a ; a
";
RegexOptions options = RegexOptions.IgnorePatternWhitespace | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}