// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?xm)(?xm)^
(?:|
[^;"'\r\n]*
(?:
(?:'[^'\r\n]*')|
(?:"[^"\r\n]*")
)*
)
\h*
;\h*([^\r\n]*)"#).unwrap();
let string = "; test
; \"test\"
; \"test'
; 'test'
; 'test\"
$x='' ; chaîne \"vide\"
$x=\"\" ; chaîne \"vide\"
$x=\"\" ; chaîne 'vide'
$x = \"aa;aa\" ; Comment-line
$x = \"a\" ;$x='b'
$;x = \"aa;aa\" ; Comment-line
$x=' '' '';'' \";\" \"'' ''\" \"''\"' ; chaîne \"vide\"
$x=' '' '';'' \";\" \"'' ''\" \"''\"' ; chaîne 'vide'
$x=\" ' ';' \"\";\"\" \"\"' '\"\" \"\"'\"\"\" ; chaîne \"vide\"
$x=\" ' ';' \"\";\"\" \"\"' '\"\" \"\"'\"\"\" ; chaîne 'vide'
\"\" ; commentaire
$x = 'bb;b'
$x = \"bb;b\"
$x = \" \" & \"bb\"
;;;;
; ; ;\";'
\";iii
';uuu;uuu\";uuu';aa
; test
\" i \" ; a ; a
\" i \" ; ; a ; a
\" i \" ; a ; a ; a
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}