import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?xm)^\n"
+ "(?:|\n"
+ " [^;\"'\\r\\n]*\n"
+ " (?:\n"
+ " (?:'[^'\\r\\n]*')|\n"
+ " (?:\"[^\"\\r\\n]*\")\n"
+ " )*\n"
+ ")\n"
+ "\\h*\n"
+ ";\\h*([^\\r\\n]*)";
final String string = "; test\n"
+ "; \"test\"\n"
+ "; \"test'\n"
+ "; 'test'\n"
+ "; 'test\"\n"
+ "$x='' ; chaîne \"vide\"\n"
+ "$x=\"\" ; chaîne \"vide\"\n"
+ "$x=\"\" ; chaîne 'vide'\n"
+ "$x = \"aa;aa\" ; Comment-line\n"
+ "$x = \"a\" ;$x='b'\n"
+ "$;x = \"aa;aa\" ; Comment-line\n"
+ "$x=' '' '';'' \";\" \"'' ''\" \"''\"' ; chaîne \"vide\"\n"
+ "$x=' '' '';'' \";\" \"'' ''\" \"''\"' ; chaîne 'vide'\n"
+ "$x=\" ' ';' \"\";\"\" \"\"' '\"\" \"\"'\"\"\" ; chaîne \"vide\"\n"
+ "$x=\" ' ';' \"\";\"\" \"\"' '\"\" \"\"'\"\"\" ; chaîne 'vide'\n\n"
+ "\"\" ; commentaire\n\n"
+ "$x = 'bb;b'\n"
+ "$x = \"bb;b\"\n"
+ "$x = \" \" & \"bb\"\n\n"
+ ";;;;\n"
+ "; ; ;\";'\n"
+ "\";iii\n"
+ "';uuu;uuu\";uuu';aa\n"
+ " ; test\n"
+ "\" i \" ; a ; a\n"
+ "\" i \" ; ; a ; a\n"
+ "\" i \" ; a ; a ; a\n";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}