# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\bf\b((?!')(?!\")(?!\())/FOUND/gmi;t' <<< "f
f(aaa) + f
f + 2
a+ fcc + 9 -f
if({f_b}=0,' -B',' -F -B')
B + 5 + f(aaa, b)
b(aaa) + b
\"b\"
'f'
a=-f(aaa)"