re = /\bf\b((?!')(?!\")(?!\())/mi
str = 'f
f(aaa) + f
f + 2
a+ fcc + 9 -f
if({f_b}=0,\' -B\',\' -F -B\')
B + 5 + f(aaa, b)
b(aaa) + b
"b"
\'f\'
a=-f(aaa)'
subst = 'FOUND'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result