use strict;
my $str = 'f
f(aaa) + f
f + 2
a+ fcc + 9 -f
if({f_b}=0,\' -B\',\' -F -B\')
B + 5 + f(aaa, b)
b(aaa) + b
"b"
\'f\'
a=-f(aaa)';
my $regex = qr/\bf\b((?!')(?!\")(?!\())/mip;
my $subst = 'FOUND';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";