import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bf\\b((?!')(?!\\\")(?!\\())";
final String string = "f\n"
+ "f(aaa) + f\n"
+ "f + 2\n"
+ "a+ fcc + 9 -f\n"
+ "if({f_b}=0,' -B',' -F -B')\n"
+ "B + 5 + f(aaa, b)\n"
+ "b(aaa) + b\n"
+ "\"b\"\n"
+ "'f'\n"
+ "a=-f(aaa)";
final String subst = "FOUND";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}