#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)\bf\b((?!')(?!\")(?!\())"
Local $sString = "f" & @CRLF & _
"f(aaa) + f" & @CRLF & _
"f + 2" & @CRLF & _
"a+ fcc + 9 -f" & @CRLF & _
"if({f_b}=0,' -B',' -F -B')" & @CRLF & _
"B + 5 + f(aaa, b)" & @CRLF & _
"b(aaa) + b" & @CRLF & _
""b"" & @CRLF & _
"'f'" & @CRLF & _
"a=-f(aaa)"
Local $sSubst = "FOUND"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)