using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bf\b((?!')(?!\"")(?!\())";
string substitution = @"FOUND";
string input = @"f
f(aaa) + f
f + 2
a+ fcc + 9 -f
if({f_b}=0,' -B',' -F -B')
B + 5 + f(aaa, b)
b(aaa) + b
""b""
'f'
a=-f(aaa)";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}