#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\\[cgl]__?)([a-z]+)_([a-z_]+)(_[A-Za-z]+)"
Local $sString = "\keys_define:nn { test } {" & @CRLF & _
" c .tl_set:N = \l_test_some_tl," & @CRLF & _
" d .tl_set:N = \l__test_test_variable_tl" & @CRLF & _
"}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")