$re = '/(\\\\[cgl]__?)([a-z]+)_([a-z_]+)(_[A-Za-z]+)/';
$str = '\\keys_define:nn { test } {
c .tl_set:N = \\l_test_some_tl,
d .tl_set:N = \\l__test_test_variable_tl
}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);