package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\\[cgl]__?)([a-z]+)_([a-z_]+)(_[A-Za-z]+)`)
var str = `\keys_define:nn { test } {
c .tl_set:N = \l_test_some_tl,
d .tl_set:N = \l__test_test_variable_tl
}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}