const regex = /(\\[cgl]__?)([a-z]+)_([a-z_]+)(_[A-Za-z]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\\\[cgl]__?)([a-z]+)_([a-z_]+)(_[A-Za-z]+)', 'g')
const str = `\\keys_define:nn { test } {
c .tl_set:N = \\l_test_some_tl,
d .tl_set:N = \\l__test_test_variable_tl
}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}