import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\\\[cgl]__?)([a-z]+)_([a-z_]+)(_[A-Za-z]+)";
final String string = "\\keys_define:nn { test } {\n"
+ " c .tl_set:N = \\l_test_some_tl,\n"
+ " d .tl_set:N = \\l__test_test_variable_tl\n"
+ "}\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}