import re
regex = re.compile(r"(\\[cgl]__?)([a-z]+)_([a-z_]+)(_[A-Za-z]+)")
test_str = ("\\keys_define:nn { test } {\n"
" c .tl_set:N = \\l_test_some_tl,\n"
" d .tl_set:N = \\l__test_test_variable_tl\n"
"}\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")