re = /(\\[cgl]__?)([a-z]+)_([a-z_]+)(_[A-Za-z]+)/
str = '\\keys_define:nn { test } {
c .tl_set:N = \\l_test_some_tl,
d .tl_set:N = \\l__test_test_variable_tl
}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end