using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\\[cgl]__?)([a-z]+)_([a-z_]+)(_[A-Za-z]+)";
string input = @"\keys_define:nn { test } {
c .tl_set:N = \l_test_some_tl,
d .tl_set:N = \l__test_test_variable_tl
}
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}