# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\<\\/span\>\<\\/td\>)[\n]?.*((?<=\>).+(?=\<))//g;t' <<< "</span></td>
<td width=\"1%\" align=\"right\" nowrap=\"nowrap\" class=\"small inner\" >190 MB</td>
<td width=\"1%\" align=\"center\" nowrap=\"nowrap\" class=\"small inner\" >15</td>"