import re
regex = re.compile(r"(?<=\<\/span\>\<\/td\>)[\n]?.*((?<=\>).+(?=\<))")
test_str = ("</span></td>\n"
"<td width=\"1%\" align=\"right\" nowrap=\"nowrap\" class=\"small inner\" >190 MB</td>\n"
"<td width=\"1%\" align=\"center\" nowrap=\"nowrap\" class=\"small inner\" >15</td>")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)