const regex = /(?<=\<\/span\>\<\/td\>)[\n]?.*((?<=\>).+(?=\<))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\<\\\/span\\>\\<\\\/td\\>)[\\n]?.*((?<=\\>).+(?=\\<))', 'g')
const str = `</span></td>
<td width="1%" align="right" nowrap="nowrap" class="small inner" >190 MB</td>
<td width="1%" align="center" nowrap="nowrap" class="small inner" >15</td>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);