use strict;
my $str = '</span></td>
<td width="1%" align="right" nowrap="nowrap" class="small inner" >190 MB</td>
<td width="1%" align="center" nowrap="nowrap" class="small inner" >15</td>';
my $regex = qr/(?<=\<\/span\>\<\/td\>)[\n]?.*((?<=\>).+(?=\<))/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";