package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"host_ip"[\n\s.\w:",\[\]\/\?=\-;]*(\})`)
var str = `[
{
"city": "Bengalur",
"country": "IN",
"host_ip": "165.22.208.196",
"is_promoting": 0,
"is_recommend": 0,
"plugins": [
"ss://165.22.208.196:443?plugin=vest-udp;outbound=vmess"
],
"server_load": 2,
"service_type": 7
},`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}