import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"host_ip\"[\\n\\s.\\w:\",\\[\\]\\/\\?=\\-;]*(\\})";
final String string = "[\n"
+ " {\n"
+ " \"city\": \"Bengalur\",\n"
+ " \"country\": \"IN\",\n"
+ " \"host_ip\": \"165.22.208.196\",\n"
+ " \"is_promoting\": 0,\n"
+ " \"is_recommend\": 0,\n"
+ " \"plugins\": [\n"
+ " \"ss://165.22.208.196:443?plugin=vest-udp;outbound=vmess\"\n"
+ " ],\n"
+ " \"server_load\": 2,\n"
+ " \"service_type\": 7\n"
+ " },";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}