import re
regex = re.compile(r"\"host_ip\"[\n\s.\w:\",\[\]\/\?=\-;]*(\})", flags=re.MULTILINE)
test_str = ("[\n"
" {\n"
" \"city\": \"Bengalur\",\n"
" \"country\": \"IN\",\n"
" \"host_ip\": \"165.22.208.196\",\n"
" \"is_promoting\": 0,\n"
" \"is_recommend\": 0,\n"
" \"plugins\": [\n"
" \"ss://165.22.208.196:443?plugin=vest-udp;outbound=vmess\"\n"
" ],\n"
" \"server_load\": 2,\n"
" \"service_type\": 7\n"
" },")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")