const regex = /"host_ip"[\n\s.\w:",\[\]\/\?=\-;]*(\})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"host_ip"[\\n\\s.\\w:",\\[\\]\\\/\\?=\\-;]*(\\})', 'gm')
const str = `[
{
"city": "Bengalur",
"country": "IN",
"host_ip": "165.22.208.196",
"is_promoting": 0,
"is_recommend": 0,
"plugins": [
"ss://165.22.208.196:443?plugin=vest-udp;outbound=vmess"
],
"server_load": 2,
"service_type": 7
},`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}