re = /"host_ip"[\n\s.\w:",\[\]\/\?=\-;]*(\})/m
str = '[
{
"city": "Bengalur",
"country": "IN",
"host_ip": "165.22.208.196",
"is_promoting": 0,
"is_recommend": 0,
"plugins": [
"ss://165.22.208.196:443?plugin=vest-udp;outbound=vmess"
],
"server_load": 2,
"service_type": 7
},'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end