#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\+{0,2}\d+(?:\b \b|\d)+$"
Local $sString = "+41 51 271 21 44" & @CRLF & _
"++51 271 21 44" & @CRLF & _
"++51 271 21 44" & @CRLF & _
"051 271 21 44" & @CRLF & _
"0512712144" & @CRLF & _
"0041512712144" & @CRLF & _
"051 271 21 44" & @CRLF & _
"051 271 21a44" & @CRLF & _
"0041 51 271 21 44" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")