// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\+{0,2}\d+(?:\b \b|\d)+$").unwrap();
let string = "+41 51 271 21 44
++51 271 21 44
++51 271 21 44
051 271 21 44
0512712144
0041512712144
051 271 21 44
051 271 21a44
0041 51 271 21 44
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}