const regex = /^\+{0,2}\d+(?:\b \b|\d)+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\+{0,2}\\d+(?:\\b \\b|\\d)+$', 'gm')
const str = `+41 51 271 21 44
++51 271 21 44
++51 271 21 44
051 271 21 44
0512712144
0041512712144
051 271 21 44
051 271 21a44
0041 51 271 21 44
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}