using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\+{0,2}\d+(?:\b \b|\d)+$";
string input = @"+41 51 271 21 44
++51 271 21 44
++51 271 21 44
051 271 21 44
0512712144
0041512712144
051 271 21 44
051 271 21a44
0041 51 271 21 44
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}