import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\+{0,2}\\d+(?:\\b \\b|\\d)+$";
final String string = "+41 51 271 21 44\n"
+ "++51 271 21 44\n"
+ "++51 271 21 44\n"
+ "051 271 21 44\n"
+ "0512712144\n"
+ "0041512712144\n"
+ "051 271 21 44\n"
+ "051 271 21a44\n"
+ "0041 51 271 21 44\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}