package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\+{0,2}\d+(?:\b \b|\d)+$`)
var str = `+41 51 271 21 44
++51 271 21 44
++51 271 21 44
051 271 21 44
0512712144
0041512712144
051 271 21 44
051 271 21a44
0041 51 271 21 44
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}