use strict;
my $str = '+41 51 271 21 44
++51 271 21 44
++51 271 21 44
051 271 21 44
0512712144
0041512712144
051 271 21 44
051 271 21a44
0041 51 271 21 44
';
my $regex = qr/^\+{0,2}\d+(?:\b \b|\d)+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}