# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\+{0,2}\d+(?:\b \b|\d)+$"
test_str = ("+41 51 271 21 44\n"
"++51 271 21 44\n"
"++51 271 21 44\n"
"051 271 21 44\n"
"0512712144\n"
"0041512712144\n"
"051 271 21 44\n"
"051 271 21a44\n"
"0041 51 271 21 44\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.