re = /^\+{0,2}\d+(?:\b \b|\d)+$/m
str = '+41 51 271 21 44
++51 271 21 44
++51 271 21 44
051 271 21 44
0512712144
0041512712144
051 271 21 44
051 271 21a44
0041 51 271 21 44
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end