using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(\""uuid\"":\""(?<uuidValue>\w{8}-(?:(\w{4}-){3})\w{12}))\"")";
string input = @"{""uuid"":""ae7f5827-e29e-462f-b5f7-ace16cf5b18f"",""orderId"":""ATLAS48315";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}