import re
regex = re.compile(r"(?:(\"uuid\":\"(?<uuidValue>\w{8}-(?:(\w{4}-){3})\w{12}))\")")
test_str = "{\"uuid\":\"ae7f5827-e29e-462f-b5f7-ace16cf5b18f\",\"orderId\":\"ATLAS48315"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")