package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:(\"uuid\":\"(?<uuidValue>\w{8}-(?:(\w{4}-){3})\w{12}))\")`)
var str = `{"uuid":"ae7f5827-e29e-462f-b5f7-ace16cf5b18f","orderId":"ATLAS48315`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}