import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(\\\"uuid\\\":\\\"(?<uuidValue>\\w{8}-(?:(\\w{4}-){3})\\w{12}))\\\")";
final String string = "{\"uuid\":\"ae7f5827-e29e-462f-b5f7-ace16cf5b18f\",\"orderId\":\"ATLAS48315";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}