use strict;
my $str = '{"uuid":"ae7f5827-e29e-462f-b5f7-ace16cf5b18f","orderId":"ATLAS48315';
my $regex = qr/(?:(\"uuid\":\"(?<uuidValue>\w{8}-(?:(\w{4}-){3})\w{12}))\")/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}