// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?:(\"uuid\":\"(?<uuidValue>\w{8}-(?:(\w{4}-){3})\w{12}))\")"#).unwrap();
let string = "{\"uuid\":\"ae7f5827-e29e-462f-b5f7-ace16cf5b18f\",\"orderId\":\"ATLAS48315";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}