import Foundation
let pattern = #"(?:(\"uuid\":\"(?<uuidValue>\w{8}-(?:(\w{4}-){3})\w{12}))\")"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"{"uuid":"ae7f5827-e29e-462f-b5f7-ace16cf5b18f","orderId":"ATLAS48315"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}