re = /(?:(\"uuid\":\"(?<uuidValue>\w{8}-(?:(\w{4}-){3})\w{12}))\")/
str = '{"uuid":"ae7f5827-e29e-462f-b5f7-ace16cf5b18f","orderId":"ATLAS48315'
# Print the match result
str.match(re) do |match|
puts match.to_s
end