#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?si)\s*<img\b(?>(?!src=).)*?\/>\s*"
Local $sString = "<html>" & @CRLF & _
" <img src="someurl" alt="something" />" & @CRLF & _
" <img alt="something" />" & @CRLF & _
" <img alt="somethingelse"" & @CRLF & _
" att='val' />" & @CRLF & _
"<html />"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)