import Foundation
let pattern = #"(?si)\s*<img\b(?>(?!src=).)*?\/>\s*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<html>
<img src="someurl" alt="something" />
<img alt="something" />
<img alt="somethingelse"
att='val' />
<html />
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)