use strict;
my $str = '<html>
<img src="someurl" alt="something" />
<img alt="something" />
<img alt="somethingelse"
att=\'val\' />
<html />';
my $regex = qr/(?si)\s*<img\b(?>(?!src=).)*?\/>\s*/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";