using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?si)\s*<img\b(?>(?!src=).)*?\/>\s*";
string substitution = @"";
string input = @"<html>
<img src=""someurl"" alt=""something"" />
<img alt=""something"" />
<img alt=""somethingelse""
att='val' />
<html />";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}