re = /(?si)\s*<img\b(?>(?!src=).)*?\/>\s*/
str = '<html>
<img src="someurl" alt="something" />
<img alt="something" />
<img alt="somethingelse"
att=\'val\' />
<html />'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result